БСП: Дополнительная обработка (Регламенты) + Расширения, примеры от сложного к универсальному

Публикация № 829920

Разработка - Практика программирования

РЗ Регламентное задание БСП Дополнительные обработки Отладка Обработка Расширения Расширение конфигурации 8.3

Продолжение статьи «БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному». Пойдем от финального примера той статьи и сделаем несколько шагов навстречу к универсальному решению.

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Для экспериментов я использовал Платформы 8.3.10.2650 и 8.3.12.1440, конфигурации БСП 2.4.6.56 и 3.0.1.135.

Завершили мы предыдущую часть так -> Два регламента, форма с ручным запуском и сохранение параметров для регламентов.

Как Вы понимаете, с одной стороны удобно добавлять регламентные задания в дополнительную обработку и обновлять ее, с другой стороны, если нам нужно только поправить код, это опять нужно править обработку и ее закидывать в дополнительные отчеты и обработки. Да и добавление новых регламентных заданий несет некий дискомфорт… Давайте попытаемся сделать мир лучше и удобнее!

Содержание:

Задача 1. Частичный перенос функционала в расширение 8.3.10

Задача 2. Используем расширение 8.3.12 по максимуму

Решение от Петра Малыгина

Заключение

Задачи и решения.

Задача 1: Вынести добавление регламентных заданий из обработки в расширение.

Добавляем расширение конфигурации

Добавляем модуль БПСПро_ОбщийМодуль и создаем процедуру ЗаполнитьКоманды (ПараметрыРегистрации) Экспорт

Нарочно оставляем ее пустой, это нужно, чтобы показать еще одну проблему.

Создаем копированием обработку из предыдущей части и в модуле меняем функцию описания:

СведенияОВнешнейОбработке
 
 

Так же меняем у обработки имя(БСППро_Регламены) и синоним(БСППро: Регламенты)

Сохраняем обработку и добавляем ее в нашу конфигурацию для тестов БСП демо.

Теперь в расширение добавим регламенты.

ЗаполнитьКоманды
 
 
Процедура ЗаполнитьКоманды(ПараметрыРегистрации) Экспорт
	//Регламент1
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Задача 1 регламент'");
	НоваяКоманда.Идентификатор = "Задача1Регламент";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
	НоваяКоманда.ПоказыватьОповещение = Истина;
	
	//Регламент2
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Задача 2 регламент'");
	НоваяКоманда.Идентификатор = "Задача2Регламент";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
	НоваяКоманда.ПоказыватьОповещение = Истина;
		
КонецПроцедуры

 

Заходим в нашу обработку и что мы видим? Регламентов нет. Открываем форму и видим, что список с регламентами работает.

Мы даже вручную его можем выполнить!

На самом деле все очень просто, список в дополнительных обработках обновляется в момент загрузки файла.

Давайте починим этот момент, тем более у нас на вооружении расширение конфигурации.

Находим справочник ДополнительныеОтчетыИОбработки и добавляем ФормуЭлемента в расширение.

Добавляем команду «ОбновитьКомандыПро» на форму

Прописываем действие:

Для БСП младше 3.0.3.XX БПСПро_ОбновитьКомандыПроПосле
 
 
//Обновляем регламентные задания
&НаКлиенте
Процедура БПСПро_ОбновитьКомандыПроПосле(Команда)
	ПараметрыРегистрации = Новый Структура;
	ПараметрыРегистрации.Вставить("Успех", Ложь);
	ПараметрыРегистрации.Вставить("АдресДанныхОбработки", АдресДанныхОбработки);

	ПараметрыРегистрации.Вставить("ИмяФайла", Объект.ИмяФайла);

	ПараметрыРегистрации.Вставить("ОтключатьПубликацию", Ложь);
	ПараметрыРегистрации.Вставить("ОтключатьКонфликтующие", Ложь);
	ПараметрыРегистрации.Вставить("Конфликтующие", Новый СписокЗначений);
	ПараметрыРегистрации.Вставить("ЭтоОтчет", Ложь);

	ОбновлениеИзФайлаМеханикаНаСервере(ПараметрыРегистрации);

	// Обработка результата работы сервера.
	Если ПараметрыРегистрации.Успех Тогда
		ОповещениеЗаголовок = НСтр("ru = 'Команды обновлены!'");
		ПоказатьОповещениеПользователя(ОповещениеЗаголовок);
		ОбновлениеИзФайлаЗавершение(Неопределено, ПараметрыРегистрации);
	КонецЕсли;
КонецПроцедуры

 

 
 UPD 01.10.2019 Для БСП старше 3.0.3.XX БПСПро_ОбновитьКомандыПроПосле
//Обновляем регламентные задания
&НаКлиенте
Процедура БПСПро_ОбновитьКомандыПроПосле(Команда)
	ПараметрыРегистрации = Новый Структура;
	ПараметрыРегистрации.Вставить("Успех", Ложь);
	ПараметрыРегистрации.Вставить("АдресДанныхОбработки", АдресДанныхОбработки);

	ПараметрыРегистрации.Вставить("ИмяФайла", Объект.ИмяФайла);

	ПараметрыРегистрации.Вставить("ОтключатьПубликацию", Ложь);
	ПараметрыРегистрации.Вставить("ОтключатьКонфликтующие", Ложь);
	ПараметрыРегистрации.Вставить("Конфликтующие", Новый СписокЗначений);
	ПараметрыРегистрации.Вставить("ЭтоОтчет", Ложь);

	//ОбновлениеИзФайлаМеханикаНаСервере(ПараметрыРегистрации);
	ОбновитьИзФайлаИСообщить(ПараметрыРегистрации);
	
	// Обработка результата работы сервера.
	Если ПараметрыРегистрации.Успех Тогда
		ОповещениеЗаголовок = НСтр("ru = 'Команды обновлены!'");
		ПоказатьОповещениеПользователя(ОповещениеЗаголовок);
		//ОбновлениеИзФайлаЗавершение(Неопределено, ПараметрыРегистрации);
		ОбновитьИзФайлаЗавершение(Неопределено, ПараметрыРегистрации);
	КонецЕсли;
КонецПроцедуры

 

Сразу скажу: Вырезал из типовой все, что понадобится для регламентов, для других типов команд не пробовал обновлять!

Проверяем:

Заполним параметры:

Проверим, работают ли регламенты, заполним время и подождем…

Первая задача выполнена!

Задача 2: Добавить возможность добавления регламентных заданий и возможность редактирования выполняемого кода без входа в конфигуратор (чтобы было максимально просто).

Для решения этой задачи возможностей расширения 8.3.10 будет недостаточно. Все, что нужно нам умеет 8.3.11.

В платформе 8.3.11 реализована возможность добавлять в расширение конфигурации собственные справочники, документы, планы обмена и регистры сведений.

Повторюсь, я считал и считаю 8.3.11, как и 8.3.9 «Мертворожденными» релизами!  Почему?

Потому, что:

1) 8.3.9 Фирма 1С официально перепрыгнула. То есть, шли релизы типовых конфигураций под 8.3.8, а затем сразу 8.3.10.

2) БСП 3.0 уже идет под 8.3.12 и планируемые конфигурации на сентябрь, тоже анонсируются с 8.3.12.

Поэтому данную задачу выполняем под 8.3.12 и БСП 3.0, с заделом на будущее.

Устанавливаем Демо БСП 3.0 и переносим в нее свои наработки.

Сразу скажу, я показываю только вариант, он еще будет далек от совершенства, поэтому прошу не ругать.

По-хорошему для универсального решения (не только для регламентов) нужно создавать справочник Команды с реквизитами и типами, соответствующими таблицы Команды справочника ДополнительныеОтчетыИОбработки.

Но, мы делаем решение по регламентам. Создадим справочник БПСПро_Регламенты.

                -"КлючРЗ" с типом "Строка(256)"

                -"Идентификатор" с типом "Строка(100)"

                -"Активно" с типом "Булево"

Сделаем КлючРЗ - РежимВыбораИзСписка и создадим процедуру с заполнение списка. Я буду считать, что все обработки нужные нам начинаются с «БСППро»

ПриСозданииНаСервере
 
 
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	Запрос = Новый Запрос("ВЫБРАТЬ
	                      |	ДополнительныеОтчетыИОбработки.ИмяОбъекта КАК КлючРЗ
	                      |ИЗ
	                      |	Справочник.ДополнительныеОтчетыИОбработки КАК ДополнительныеОтчетыИОбработки
	                      |ГДЕ
	                      |	НЕ ДополнительныеОтчетыИОбработки.ПометкаУдаления
	                      |	И ДополнительныеОтчетыИОбработки.ИмяОбъекта ПОДОБНО ""БСППро%""");
	
	Элементы.КлючРЗ.СписокВыбора.ЗагрузитьЗначения(Запрос.Выполнить().Выгрузить().ВыгрузитьКолонку("КлючРЗ"));	
КонецПроцедуры

 

Создадим подсистему БПСПро_БСП и поправим модуль БПСПро_ОбщийМодуль (Процедура ЗаполнитьКоманды)

ЗаполнитьКоманды
 
 
Процедура ЗаполнитьКоманды(ПараметрыРегистрации,КлючРЗ) Экспорт
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	БПСПро_Регламенты.Наименование КАК Наименование,
		|	БПСПро_Регламенты.Идентификатор КАК Идентификатор
		|ИЗ
		|	Справочник.БПСПро_Регламенты КАК БПСПро_Регламенты
		|ГДЕ
		|	НЕ БПСПро_Регламенты.ПометкаУдаления
		|	И БПСПро_Регламенты.КлючРЗ = &КлючРЗ
		|	И БПСПро_Регламенты.Активно";
	
	Запрос.УстановитьПараметр("КлючРЗ", КлючРЗ);
	РезультатЗапроса = Запрос.Выполнить();

	//Заполняем команды из справочника регламентов
	Если не РезультатЗапроса.Пустой() Тогда 
		ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
		Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
			НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
			НоваяКоманда.Представление = НСтр("ru = '"+ВыборкаДетальныеЗаписи.Наименование+"'");
			НоваяКоманда.Идентификатор = ВыборкаДетальныеЗаписи.Идентификатор;
			НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
			НоваяКоманда.ПоказыватьОповещение = Истина;
		КонецЦикла;
	КонецЕсли;	
КонецПроцедуры

 

В модуле обработки изменяем функцию СведенияОВнешнейОбработке, меняем одну строчку.

Было: БПСПро_ОбщийМодуль.ЗаполнитьКоманды(ПараметрыРегистрации);

Стало: БПСПро_ОбщийМодуль.ЗаполнитьКоманды(ПараметрыРегистрации,ЭтотОбъект.Метаданные().Имя);

Обновляем и проверяем.

Возможность добавления регламентных заданий без входа в конфигуратор сделана, теперь сделаем возможность добавления кода.

По-хорошему, нужен справочник с Командами и параметрами, но я не ставлю целью сделать продукт для продажи. Моя цель показать сам принцип. Поэтому создаем справочник «БПСПро_КодВыполненияРегламенов»

                -"Идентификатор" с типом "Строка(100)"

                -"ТекстКоманды" с типом "Строка(неограниченной длинны)"

                -"Параметры" таблица значений

                               -"Имя" с типом "Строка(50)" (но лучше создать справочник параметров и использовать ссылку)

                               -"ЗначениеПоУмолчанию" составной тип "Строка, ПеречислениеСсылка.ЦветаЗаметок"(для нашего примера)

Правим справочник «БПСПро_Регламенты», добавляем реквизит КодВыполнения с типом "СправочникСсылка.БПСПро_КодВыполненияРегламенов" и табличную часть Параметры.

При изменении «Код выполнения» выполняем следующий код:

КодВыполненияПриИзменении
 
 
&НаКлиенте
Процедура КодВыполненияПриИзменении(Элемент)
	КодВыполненияПриИзмененииНаСервере();
КонецПроцедуры
&НаСервере
Процедура КодВыполненияПриИзмененииНаСервере()
	//Чистим если надо
	Если Объект.Параметры.Количество() > 0 Тогда 
		Объект.Параметры.Очистить();
	КонецЕсли;

	Если ЗначениеЗаполнено(Объект.КодВыполнения) Тогда 
		//Заполняем значениями по умолчанию		
		Для Каждого строкаПараметры из Объект.КодВыполнения.Параметры Цикл 
			новыйПараметр = Объект.Параметры.Добавить();	
			новыйПараметр.Имя = строкаПараметры.Имя;
			новыйПараметр.Значение = строкаПараметры.ЗначениеПоУмолчанию;
		КонецЦикла;		
	КонецЕсли;		
КонецПроцедуры

 

В модуль БПСПро_ОбщийМодуль добавляем процедуру ВыполнитьКомандуРЗ

ВыполнитьКомандуРЗ
 
 
Процедура ВыполнитьКомандуРЗ(ПараметрыВыполнения) Экспорт
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ ПЕРВЫЕ 1
		|	БПСПро_Регламенты.Ссылка КАК Ссылка,
		|	БПСПро_Регламенты.КодВыполнения КАК КодВыполнения
		|ИЗ
		|	Справочник.БПСПро_Регламенты КАК БПСПро_Регламенты
		|ГДЕ
		|	НЕ БПСПро_Регламенты.ПометкаУдаления
		|	И БПСПро_Регламенты.КлючРЗ = &КлючРЗ
		|	И БПСПро_Регламенты.Активно
		|	И БПСПро_Регламенты.Идентификатор = &Идентификатор";
	
	Запрос.УстановитьПараметр("КлючРЗ", ПараметрыВыполнения.КлючРЗ);
	Запрос.УстановитьПараметр("Идентификатор", ПараметрыВыполнения.Идентификатор);

	РезультатЗапроса = Запрос.Выполнить();
	
	//Заполняем параметры и выполняем команду
	Если не РезультатЗапроса.Пустой() Тогда 

		ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
		
		Если ВыборкаДетальныеЗаписи.Следующий() Тогда 
			
			//Параметры заполнения
			ПараметрыРЗ = Новый Структура;
			Для Каждого СтрокаПараметровПоУмолчанию из ВыборкаДетальныеЗаписи.КодВыполнения.Параметры Цикл 
				
				ПараметрыОтбора = Новый Структура;
				ПараметрыОтбора.Вставить("Имя", СтрокаПараметровПоУмолчанию.Имя);
				НайденныеСтроки = ВыборкаДетальныеЗаписи.Ссылка.Параметры.НайтиСтроки(ПараметрыОтбора);
				Если НайденныеСтроки.Количество() = 0 Тогда 
					ПараметрыРЗ.Вставить(СтрокаПараметровПоУмолчанию.Имя, СтрокаПараметровПоУмолчанию.ЗначениеПоУмолчанию);	
				Иначе
					ПараметрыРЗ.Вставить(СтрокаПараметровПоУмолчанию.Имя, НайденныеСтроки[0].Значение);		
				КонецЕсли;
				
			КонецЦикла;	
	        ПараметрыВыполнения.Вставить("ПараметрыРЗ",ПараметрыРЗ);
			
			//Выполняем команду по регламенту
			Попытка
				Выполнить(ВыборкаДетальныеЗаписи.КодВыполнения.ТекстКоманды);
			Исключение
				//СообщениеОбОшибке = ОписаниеОшибки();
			КонецПопытки;	
		КонецЕсли;
	
	КонецЕсли;
КонецПроцедуры

 

В модуле обработки правим ВыполнитьКоманду. По идее можно оставить только ВыполнитьКоманду и СведенияОВнешнейОбработке остальное можно удалить.

ВыполнитьКоманду
 
 

Из формы обработки убираем все лишнее:

Код модуля формы:
 
 

Теперь нам нужно сохранить все изменения и в клиентской части заполнить текст команды, параметры, обновить обработку и назначить время для РЗ.

Создаем новый элемент справочника «Код выполнения регламентов (БСППро)»

Текст команды забираем тот, что был написан в 3 задании предыдущей статьи (Процедура СоздатьНовыйЭлементСправочникаЗаметки)

Текст команды
 
 
	//Создаем новый элемент справочника
	ТекущийОбъект = Справочники.Заметки.СоздатьЭлемент();
	
	ДатаТекСеанса = ТекущаяДатаСеанса();
	
	//Формируем текст для Содержания
	ФорматированныйТекст = Новый ФорматированныйДокумент;
	
	//Обрабатываем Параметры
	перТекстСодержания = "Заметка создана ";
	перПометка = Перечисления.ЦветаЗаметок.Красный;
	Если ПараметрыВыполнения.Свойство("ПараметрыРЗ") Тогда 
		Если ТипЗнч(ПараметрыВыполнения.ПараметрыРЗ) = Тип("Структура") Тогда 
			Если ПараметрыВыполнения.ПараметрыРЗ.Свойство("ТекстСодержания") Тогда 
				Если ЗначениеЗаполнено(ПараметрыВыполнения.ПараметрыРЗ.ТекстСодержания) Тогда 
					перТекстСодержания = ПараметрыВыполнения.ПараметрыРЗ.ТекстСодержания;	
				КонецЕсли;	
			КонецЕсли;
			
			Если ПараметрыВыполнения.ПараметрыРЗ.Свойство("Пометка") Тогда 
				Если ЗначениеЗаполнено(ПараметрыВыполнения.ПараметрыРЗ.Пометка) Тогда 
					перПометка = ПараметрыВыполнения.ПараметрыРЗ.Пометка;	
				КонецЕсли;	
			КонецЕсли;

		КонецЕсли;	
	КонецЕсли;
	
	//Добавили проверку регламент\форма	
	ФорматированныйТекст.Добавить(перТекстСодержания + ?(ПараметрыВыполнения.ВидЗапускаРегламент,"регламентом","вручную") + " в "+Строка(ДатаТекСеанса), Тип("ТекстФорматированногоДокумента"));
	
	ТекущийОбъект.Содержание = Новый ХранилищеЗначения(ФорматированныйТекст, Новый СжатиеДанных(9));
	
	ТекстHTML = "";
	Вложения = Новый Структура;
	ФорматированныйТекст.ПолучитьHTML(ТекстHTML, Вложения);
	
	ТекущийОбъект.ТекстСодержания	= СтроковыеФункцииКлиентСервер.ИзвлечьТекстИзHTML(ТекстHTML);
	
	ТекущийОбъект.ДатаИзменения 	= ДатаТекСеанса;
	ТекущийОбъект.Автор 			= ПараметрыСеанса.ТекущийПользователь;

	ТекущийОбъект.Пометка 			= перПометка;
	ТекущийОбъект.ДляРабочегоСтола	= Истина;
	
	ТекущийОбъект.Записать();

 

Добавляем параметры:

Теперь отредактируем ранее созданные регламенты. Выберем в них данную команду и заполним параметры.

Записываем и заменяем предыдущую дополнительную обработку на эту.

Проверяем ручной запуск и регламеты:

Вторая задача выполнена!

Хочу еще упомянуть решение Петра Малыгина

В данный момент у него есть практически готовое решение по автоматизации в части Выполнения кода. С его решением можно сделать универсальный (или почти универсальный) регламент.

Кому интересно, можно ознакомиться с видео его решения:

Описание решения

Пример решения

Ссылка на статью Петра Малыгина

Заключение:

В первой части мы рассмотрели, как сделать сложные регламенты без доработки конфигурации, но, как вы понимаете, есть свои неудобства с обновлением регламентов.

Во второй части мы сделали решение, позволяющее в будущем создавать регламенты без доработки конфигурации и без изменений в конфигураторе.

Старался расписаться максимально доступно и примеры выбрал не «Hello, world!».

Надеюсь, статьи будут вам полезны (не забывайте нажимать на звездочку), удачи в работе!

Скачать файлы

Наименование Файл Версия Размер
БСП: Дополнительная обработка + Расширение (под 8.3.12)
.zip 90,42Kb
01.10.19
12
.zip 1.0.0.2 90,42Kb 12 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. pm74 163 22.05.18 08:02 Сейчас в теме
(0) Приветствую.
Правильно ли я понял чтобы добавить новое РЗ нужно заново регистрировать обработку " БСППро: Регламенты " ?
2. dsdred 1318 22.05.18 08:28 Сейчас в теме
(1)Доброе утро.
Нужно обновить добавленную обработку.
В типовом решении БСП, нужно "Обновлять из файла" с последующем выбором обработки.
В моем решении по нажатию кнопки "Обновить команды"
3. pm74 163 22.05.18 08:30 Сейчас в теме
(2) старые расписания не слетают при обновлении ?
4. dsdred 1318 22.05.18 08:31 Сейчас в теме
(3)Тестировал, не слетали.
5. pm74 163 22.05.18 08:32 Сейчас в теме
(4) ок , я сделал расширение для 8.3.11 нужно только привязать к обновлению регламента
выложу в ближайшее время
6. dsdred 1318 22.05.18 08:39 Сейчас в теме
(5)Хорошая новость! Добавте ссылку в Коментарии, я прямо в статью ее вставлю.
Прилагаю Пруф по регламентам
Прикрепленные файлы:
7. Бубузяка 62 23.05.18 09:24 Сейчас в теме
Спасибо, Дмитрий. На мой взгляд - это очень хорошая идея популяризация БСП.
8. dsdred 1318 23.05.18 10:55 Сейчас в теме
(7)Спасибо за отзыв.
На самом деле моя цель обширнее, эти статьи лишь начало.

Я хочу зайти через год на ИС и в заголовках больше не видеть или почти не видеть таких слов как COM, XML...
Хочу видеть HTTP, JSON.

Возможно у людей просто нет времени это изучить и статьи с картинками и описанием поменяют эту ситуацию.
Возможно через 2 года 1с программист прекратит быть ругательством среди других программистов.

Хотя конечно возможно это все утопия.
9. kadild 23.05.18 22:50 Сейчас в теме
(8) Ну рассмешили.
COM не только связь с Office. но и у другие приложения. например Adobe, imagemagick и тп.
XML - язык разметки (читаемость, описание типов, схемы и тп), а не формат данных JSON.
Откройте для себя XML Schema.

не видеть таких слов как COM, XML...
Хочу видеть HTTP, JSON.

Возможно через 2 года 1с программист прекратит быть ругательством среди других
Из-за таких рассуждений и ржут над однэссниками.
11. dsdred 1318 24.05.18 07:19 Сейчас в теме
(9)Я рад что Вас рассмешил, смех продлевает жизнь.
Я как всегда хотел написать коротко, но...
Не имею против
например Adobe, imagemagick и тп
и даже про контекст 7.7 или 6...
Имел ввиду обмен между базами 8 и предоставления данных например веберу.

Мне лично не до смеха. Загляните на закладку Библиотека и Вам даже долго искать не придется там свежий пример майская статья этого года ссылающаяся на статью 12 года одного и того же автора.

Я очень благодарен одному грамотному руководителю который 4 с небольшим года назад на тривиальную задачку, которую я сделал бы через com сказал: -Мне тут наш московский программист сказал что web сервисы быстрее, не посмотрите?
Помню как первый раз ставил апачи и пробывал, пробывал. Помню как ему демонстрировал работу и он сказал: -УЖЕ?
Затем HTTP сервисы, битва с объемом передоваемых данных и т.д.
Вот что я имел ввиду.
12. pm74 163 27.05.18 23:42 Сейчас в теме
(0) обновил публикацию , отправил модераторам https://infostart.ru/public/728511/ ,
13. dsdred 1318 28.05.18 07:38 Сейчас в теме
(12)Ссылку на статью добавил в статью.
14. pm74 163 28.05.18 09:10 Сейчас в теме
(13) появилось в общем доступе
15. vladpisklov 30.09.19 23:48 Сейчас в теме
Не подскажите что за процедура:

ОбновлениеИзФайлаМеханикаНаСервере(ПараметрыРегистрации);

а так-же:
ОбновлениеИзФайлаЗавершение(Неопределено, ПараметрыРегистрации);

При подключении расширения к базе ругается на эти процедуры.
16. dsdred 1318 01.10.19 00:10 Сейчас в теме
(15)Это процедуры на форме элемента справочника дополнительные обработки. Служат для обновления команд.

Подскажите какую версию БСП используете? Я себе установлю и посмотрю, что там изменилось на форме элемента справочника доп обработок.
17. vladpisklov 01.10.19 06:41 Сейчас в теме
18. dsdred 1318 01.10.19 10:17 Сейчас в теме
(17)Да, действительно обновилось в БСП название процедур.
Напишите мне в личку Ваш имейл я вам скину обновленное расширение.

И в статье сейчас UPD сделаю
Оставьте свое сообщение

См. также

Краткое руководство по внесению изменений в конфигурацию

Статья Программист Нет файла v8 1cv8.cf Абонемент ($m) Практика программирования

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    6961    14    sapervodichka    34       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Полезные процедуры и функции для программиста

Статья Программист Нет файла v8 1cv8.cf Россия Абонемент ($m) Практика программирования Универсальные функции

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

1 стартмани

07.10.2019    16675    7    HostHost    25       

Хороший заказчик - плохой заказчик

Статья no Нет файла Россия Бесплатно (free) О жизни

Лайфхак о том, как стать легендарным клиентом.

13.09.2019    5528    dsdred    24       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Описание формата внутреннего представления данных 1С в контексте обмена данными

Статья Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных Разработка

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    9081    7    Dementor    27       

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

Вам нравятся запросы в 1С?

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования Разработка

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    13368    4    m-rv    86       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

1С:Ассемблер. Немного летнего веселья!

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Разработка

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    19271    57    Evil Beaver    116       

Простые примеры сложных отчетов на СКД

Статья Программист Архив с данными v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    19254    17    Hatson    22       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Безопасная работа с транзакциями во встроенном языке

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    20826    8    tormozit    44       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

HTML в новой версии 8.3.14 на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки Практика программирования Разработка

Тестируем возможности HTML в новой версии 8.3.14 платформы на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX.

1 стартмани

29.01.2019    18849    77    Synoecium    40       

Работа с публикациями "Инфостарт"

Инструменты и обработки Программист Архив с данными v8 УУ Абонемент ($m) Практика программирования О сообществе WEB

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    12312    12    RocKeR_13    16       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструменты и обработки Программист Бизнес-аналитик Приложение (apk) v8 Windows Абонемент ($m) Инструментарий разработчика Практика программирования

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    19250    25    informa1555    26       

Работа с данными выбора

Инструменты и обработки Программист Архив с данными v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    28990    17    kalyaka    16       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

HTTP Сервисы: Путь к своему сервису. Часть 1

Статья Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Практика программирования WEB

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    52330    23    dsdred    24       

Жизненный цикл управляемой формы. Шпаргалка разработчика

Статья Программист Архив с данными v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Математика и алгоритмы

Прочитав когда-то давно книжку "Разработка управляемых форм", составил для себя такую схемку-напоминалку для обращения в процессе разработки. С тех пор не раз выручала и избавляла от необходимости лезть в гуглы.

1 стартмани

29.06.2018    25040    54    stas_ganiev    26       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар")

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    22400    86    m-rv    57       

Алгоритмы и регламентные задания (расширение)

Инструменты и обработки Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Абонемент ($m) Инструментарий разработчика

Универсальный механизм для создания алгоритмов и регламентных задач.

5 стартмани

28.05.2018    8328    8    pm74    39       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования БСП (Библиотека стандартных подсистем)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    33247    31    dsdred    36       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Как выполнить отчет на СКД через COM и получить данные отчета?

Статья Программист Архив с данными v8 УПП1 Россия Windows Абонемент ($m) Практика программирования

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    20653    11    wowik    3       

Работа со схемой запроса

Статья Программист Конфигурация (md, cf) v8 v8::Запросы Абонемент ($m) Инструментарий разработчика Практика программирования

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    33454    77    kalyaka    34       

​​​​​​​CorelDRAW Graphics Suite 2019 Промо

CorelDRAW – пакет профессиональных инструментов для редактирования фотографий, разработки дизайна, создания макетов страниц и векторных иллюстраций

Заполняем по шаблону (по умолчанию)

Инструменты и обработки Программист Архив с данными v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    20198    20    mvxyz    17       

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    28493    63    rpgshnik    48